Test Set Mismatch for EIA3

View previous topic View next topic Go down

Test Set Mismatch for EIA3

Post  zeshan on Tue Dec 21, 2010 9:42 pm

hi,
I am working on EIA3,an integrity algorithm based on ZUC.

I am having problem in matching of EIA3Test Set provided in Document 3 "Implementor's Test Data".

Although Test set 1 and Test set 2 of Message all zero's are being matched whereas other Test

sets for EIA3 with Messages of non-zero are not being matched.

Any help in this regard will be highly appreciated.

Regards




Test Set provided for EIA3 are matched for messages


zeshan

Posts : 11
Join date : 2010-08-16

View user profile

Back to top Go down

Any one here?

Post  kknd on Mon Jan 24, 2011 7:01 am

Evil or Very Mad Twisted Evil

kknd

Posts : 7
Join date : 2010-11-08

View user profile

Back to top Go down

Any detail?

Post  Peng Wang on Mon Jan 24, 2011 7:06 am

zeshan wrote:.......whereas other Test
sets for EIA3 with Messages of non-zero are not being matched.
Would you please post your test data?

Peng Wang

Posts : 6
Join date : 2010-10-25

View user profile

Back to top Go down

Re: Test Set Mismatch for EIA3

Post  zeshan on Thu Feb 03, 2011 9:18 pm

Test Vectors Match as i was making mistake by considering that IV is same for EEA and EIA3.

zeshan

Posts : 11
Join date : 2010-08-16

View user profile

Back to top Go down

Re: Test Set Mismatch for EIA3

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum